April 11, 2014

The Heartbleed Hit List: The Passwords You Need to Change Right Now

It’s hard to summarize lists, especially lists that are done in table formats, so you’ll just have to click the link for this one. Tumblr is on the list, so are Facebook, Amazon, and Gmail, I think those are the only services I use that are affected. I actually don’t really use Facebook a lot, I just have an account there.

The Heartbleed Hit List: The Passwords You Need to Change Right Now


articles encryption security webservices


Previous post
Tweet Marker A service for maintaining your reading position in a Twitter client. The client has to offer TweetMarker integration for this to work. Tweet Marker
Next post
Obama Decides U.S. Should Reveal, Not Exploit, Internet Security Flaws WASHINGTON — Stepping into a heated debate within the nation’s intelligence agencies, President Obama has decided that when the National Security